NEW Cover Problem on App (not Amazon Related)

ForumBug Collectors

Melde dich bei LibraryThing an, um Nachrichten zu schreiben.

NEW Cover Problem on App (not Amazon Related)

1Well-ReadNeck
Apr. 10, 12:57pm

OK, so I've been doing the laborious work of ensuring that my books do not have Amazon covers to avoid the disappearing covers issue. Now, there are some books in my collection that are showing up properly on the website, but the app still shows the generic cover. When I go on the app to edit the book, the cover is there, but it is not actually showing on my book list, where I actually go to see what I've been reading. Several of these, but not all, are book covers that I have uploaded myself.

2gilroy
Apr. 10, 4:18pm

Could you please help the developers by listing a couple of specific books for them to investigate the problem?

3kristilabrie
Apr. 12, 11:40am

>1 Well-ReadNeck: Along with the information requested at >2 gilroy:, can you let us know if you're using the iOS or Android app? What is your mobile device? Thank you!

4conceptDawg
Apr. 13, 12:02pm

This could be a problem of the app not updating the underlying book data.
Did you update the covers on the website and then look at them on the app? If so then you'll need to do a pull-to-refresh at the top level of your catalog within the app. This will force the app to update all of your book data.

For performance reasons we don't do a full reload of your entire library within the app for every action.
If that doesn't fix it then try signing out of the app and signing back into your LT account. (from the account view)

5Well-ReadNeck
Apr. 29, 10:06am

>3 kristilabrie: I'm using iOS. iPhone 12

6Well-ReadNeck
Apr. 29, 10:07am

>2 gilroy: Lily and the Octopus; The Lost Manuscript; In the Quick; Intimations (Zadie Smith); Infinite Country;You Have a Match;How to Avoid a Climate Disaster -- just to name a few

7Well-ReadNeck
Apr. 29, 10:09am

>4 conceptDawg: I did refresh and signed out and back in; then deleted app and then re-installed. Still doing this. Affecting LOTS of titles.

8Well-ReadNeck
Apr. 29, 10:10am

Oh, I should mention, when I do an edit from the app, it appears that from the edit page, the cover shows, it's just not showing on my catalog list, where I use it. Obviously, I've only done a spot check on this, but I've tried 5-10 titles.

9kristilabrie
Apr. 30, 10:06am

Thanks for this information!

Okay, testing:
- I do see that your How to Avoid a Climate Disaster is showing a generic red cover on the app, but a real cover that you've selected on .com.
- pulling down to refresh, on both the book page in the app and the "All books" page doesn't refresh the cover.
- there are, as you mentioned, numerous other generic covers showing in your catalog on the app.
- even looking at your "Cover Explorer" page there are only member-uploaded covers selected, nothing from Amazon and none without covers.

It seems the data is simply not refreshing for you, here, on the app. Passing to conceptDawg to dig into, perhaps he can see more about what's going on.

10conceptDawg
Apr. 30, 11:58am

Thanks. We are digging into this to figure out what's going on.

11Well-ReadNeck
Mai 3, 3:53pm

I've noticed that many of these when I've gone back to check on them give this message:
To change your book's cover, select a cover image below or upload your own cover image.
This book uses a custom cover (remove it).

When I hit remove it, sometimes that fixes the issue. Other times, it doesn't? And, when I try just "selecting a cover below" or uploading a new image, I still get this message.

Don't know what's causing this to pop up on some and not others. And, the default "substitute" cover is a different one than the one I have chosen as my default for books that simply don't have covers.

Not sure if that helps or complicates the issue.

12Well-ReadNeck
Mai 7, 11:05am

>9 kristilabrie: I've tried going into individual books on the app and messing around until they clear, but it only works sometimes, and I'm going to stop now before I really mess something up.

Correct, there are no Amazon covers. I was having the problems that so many others were with those covers disappearing. I changed my settings and did the work of selecting member covers for hundreds of books at the beginning of the year. Which seems to have stuck and is a good (if laborious) workaround for that bug on my computer. But, it was in doing this that I ran upon this app problem.

You will also notice that if you go to the weird red generic cover ones and select edit, the actual cover that I chose is showing up on that page, just not translating to the list of covers on the "your catalog" page. So, that seems to be the gap that needs to be closed.